RFC 793 inline-errata, "Transmission Control Protocol", September 1981
Source of RFC: Legacy
⚠ This RFC has been obsoleted!
Obsoleted by: RFC9293
Updated by: RFC1122, RFC3168, RFC6093, RFC6528
Area assignment: tsv
Errata-ID: 1572
- Status:
- Verified
- Type:
- Technical
- Reported By:
- Constantin Hagemeier
- Date Reported:
- 2008-10-11
- Verified by:
- Wes Eddy
- Date Verified:
- 2011-08-13
Section 3.4 says:
If the incoming segment has an ACK field, the reset takes its
sequence number from the ACK field of the segment, otherwise the
reset has sequence number zero and the ACK field is set to the sum
of the sequence number and segment length of the incoming segment.
It should say:
If the incoming segment has the ACK bit set, the reset takes its
sequence number from the ACK field of the segment, otherwise the
reset has sequence number zero and the ACK field is set to the sum
of the sequence number and segment length of the incoming segment.
Notes:
Every segment has an ACK field.