RFC 793 inline-errata, "Transmission Control Protocol", September 1981

Source of RFC: Legacy

⚠ This RFC has been obsoleted!

Obsoleted by: RFC9293

Updated by: RFC1122, RFC3168, RFC6093, RFC6528

Area assignment: tsv

Errata-ID: 1564

Status:
Verified
Type:
Technical
Reported By:
Constantin Hagemeier
Date Reported:
2008-10-11
Verified by:
Wes Eddy
Date Verified:
2011-08-13

Section 3.7 says:

When the sender creates a segment and transmits it the sender advances
SND.NXT.  When the receiver accepts a segment it advances RCV.NXT and
sends an acknowledgment.  When the data sender receives an
acknowledgment it advances SND.UNA.  The extent to which the values of
these variables differ is a measure of the delay in the communication.
The amount by which the variables are advanced is the length of the
data in the segment.  Note that once in the ESTABLISHED state all
segments must carry current acknowledgment information.

It should say:

When the sender creates a segment and transmits it the sender advances
SND.NXT.  When the receiver accepts a segment it advances RCV.NXT and
sends an acknowledgment.  When the data sender receives an
acknowledgment it advances SND.UNA.  The extent to which the values of
these variables differ is a measure of the delay in the communication.
The amount by which the variables are advanced is the length of the
data and SYN or FIN flags in the segment.  Note that
once in the ESTABLISHED state all segments must carry current acknowledgment information.

Notes:

SYN and FIN are counted, too